VSTSynthFont 3.1 stutering (CPU Problem?)

Post Reply
RobAsticles
Posts: 2
Joined: Sat Jan 12, 2019 1:59 pm

VSTSynthFont 3.1 stutering (CPU Problem?)

Post by RobAsticles » Sat Jan 12, 2019 2:04 pm

Playing a midi-file with more than 4 Channels/Tracks the sound starts stuttering and the CPU-Meter peaks (WaveForm 9 and Mixcraft 8).

Maybe the developer could optimize the code or there is a bug in the plugin. Has it something to do with the interpolation algorythm?

Compared to the Bassmidi VST, where it is possible to use more then 16 Instances (the plugin is always only one instrument/channel/track) without any problem.

Admin
Site Admin
Posts: 362
Joined: Tue Mar 17, 2015 9:22 am

Re: VSTSynthFont 3.1 stutering (CPU Problem?)

Post by Admin » Sat Jan 12, 2019 2:47 pm

Thanks Rob,
I have not been able to reproduce this issue. I have a test file I use on a regular basis - all 16 channels will play with hundreds of voices. CPU level (using the Resource Monitor) doesn't get above 35-30% with Cubase and VSTSynthFont64. Maybe you should verify that you don't have any other processes running stealing CPU power?

RobAsticles
Posts: 2
Joined: Sat Jan 12, 2019 1:59 pm

Re: VSTSynthFont 3.1 stutering (CPU Problem?)

Post by RobAsticles » Sat Jan 12, 2019 3:11 pm

what soundfont are you using? I it possible, that using a sf2-file >100mb generates this problems?
For most of the Time i use the "Timbres Of Heaven GM_GS_XG_SFX V 3.4 Final" soundfont. Coolsoft VirtualMIdi Synth has no problems and also the BassMidi vst works. The later can only play one instrument at a time, so i need several instansces. Your plugin is in this area really better.

Admin
Site Admin
Posts: 362
Joined: Tue Mar 17, 2015 9:22 am

Re: VSTSynthFont 3.1 stutering (CPU Problem?)

Post by Admin » Sun Jan 13, 2019 10:11 am

I have many SoundFonts for testing. It is true that some of them create unnecessary voices sometimes (too many layers, too long release times). I'll make some more tests with various MIDI files, hosts and SoundFonts and share with you. I'll be back.

Admin
Site Admin
Posts: 362
Joined: Tue Mar 17, 2015 9:22 am

Re: VSTSynthFont 3.1 stutering (CPU Problem?)

Post by Admin » Sun Jan 13, 2019 1:58 pm

This is the MIDI file I use as a test:
https://www.dropbox.com/s/djex9ve59hhjx ... 9.mid?dl=0
Usually I play only the first minute or so as it starts off pretty heavily from the very beginning.

I've run some tests today with various hosts. My standard test bench is using my own host SynthFont2, simply because it is easy to add one single instance of a VST instrument to all tracks of a MIDI file. Some hosts make it hard to do that. Additionally SynthFont2 monitors the CPU load during playback and tells me the mean and peak values when done. (Finally, I use the internal playback engine in SynthFont2 as my "golden standard" when developing VSTSynthFont).

Using the SoundFont "Timbres Of Heaven GM_GS_XG_SFX V 3.4 Final" and the 32 bit version of SynthFont2 and VSTSynthFont I get this: mean CPU 19% and peak 33%. The CPU I have is rather common: Intel Core I5-4460 running at 3.2 GHz - by no way anything fancy.

Post Reply