Strange ASIO buffer size issues in REAPER

Post Reply
soliloqueen
Posts: 5
Joined: Sat Dec 08, 2018 11:45 pm

Strange ASIO buffer size issues in REAPER

Post by soliloqueen » Sat Dec 08, 2018 11:49 pm

If I'm using ASIO in REAPER with VSTSynthFont, notes happen late with random amounts of delay that is anywhere from 0 up to the buffer length in ms. Correct playback only happens at a buffer length of 44 samples (1 ms)

Admin
Site Admin
Posts: 425
Joined: Tue Mar 17, 2015 9:22 am

Re: Strange ASIO buffer size issues in REAPER

Post by Admin » Mon Dec 10, 2018 3:39 pm

I guess you mean that the buffer length must be at least 44 samples? I'm not surprised if you do not get perfect results using shorter (smaller) buffers. I will need to look at it some day. Hopefully in the near future.

soliloqueen
Posts: 5
Joined: Sat Dec 08, 2018 11:45 pm

Re: Strange ASIO buffer size issues in REAPER

Post by soliloqueen » Tue Dec 11, 2018 3:33 am

No, in fact, the other way around! the longer the buffer size, the worse the error!

soliloqueen
Posts: 5
Joined: Sat Dec 08, 2018 11:45 pm

Re: Strange ASIO buffer size issues in REAPER

Post by soliloqueen » Tue Dec 11, 2018 3:35 am

Buffer size 80ms:

https://picosong.com/wgs2Z/

Buffer size 1ms:

https://picosong.com/wgs2r/

soliloqueen
Posts: 5
Joined: Sat Dec 08, 2018 11:45 pm

Re: Strange ASIO buffer size issues in REAPER

Post by soliloqueen » Tue Dec 11, 2018 3:44 am

this carries over into offline rendering, which shouldn't even be possible

Admin
Site Admin
Posts: 425
Joined: Tue Mar 17, 2015 9:22 am

Re: Strange ASIO buffer size issues in REAPER

Post by Admin » Tue Dec 11, 2018 9:08 am

This is really odd! I'll give it a try when I get the time. Hopefully still this week.

soliloqueen
Posts: 5
Joined: Sat Dec 08, 2018 11:45 pm

Re: Strange ASIO buffer size issues in REAPER

Post by soliloqueen » Tue Dec 11, 2018 7:09 pm

Thanks! It may be an error with my asio drivers or how how they report latency, so if you can't find out what's causing it, don't worry about it! I can just turn my latency down when I use the plugin or use an audio driver that doesn't cause problems.

Admin
Site Admin
Posts: 425
Joined: Tue Mar 17, 2015 9:22 am

Re: Strange ASIO buffer size issues in REAPER

Post by Admin » Wed Dec 12, 2018 7:46 am

The thing is this: the VST plugin has now knowledge about ASIO at all. REAPER simply sends midi data to it and gives it a buffer into which to put the audio data. Whatever happens after that is totally up to the host. The plugin does not interact with the ASIO driver - or anything else than the host, for that matter. So, go figure...

Post Reply