VSTSynthFont hangs when playing instruments for the first time

Admin
Site Admin
Posts: 356
Joined: Tue Mar 17, 2015 9:22 am

Re: VSTSynthFont hangs when playing instruments for the first time

Post by Admin » Fri Oct 27, 2017 8:05 am

No, can't link in statically. The borlndmm.dll is included in the official installation file(s), though, and gets installed in Windows\System32 folder. There are actually two versions of this file: one for the 32 bit VStSynthFont version and one for the 64 bit. Silly enough they have the same name, but the installation file (different ones for 32 and 64) takes care installing the files in the correct Window\System32 folder. You can download the 32 bit version file here and place it into the correct Windows\System32 folder:
https://www.dropbox.com/s/jjrk8tfdm2re9 ... 2.rar?dl=0
Note that on 64 bit Windows, the System32 folder is actually called SysWOW64 ;)

Here is the 64 bit version:
https://www.dropbox.com/s/9lxi9ojrkxygi ... 4.rar?dl=0
(goes into the true System32 folder)

Alternatively you can run the public installation file(s) to get thing correctly set up automatically.
http://www.synthfont.com/VSTSynthFontSetup.exe
http://www.synthfont.com/VSTSynthFont64Setup.exe

mike
Posts: 27
Joined: Thu Mar 19, 2015 10:14 pm

Re: VSTSynthFont hangs when playing instruments for the first time

Post by mike » Fri Oct 27, 2017 7:25 pm

Alright, the plugin is finally loading. I think I've only ever run the 64 bit installer so I only had the 64 bit version installed.
So, the stutter seems to be gone. Nice!

However, there is one new issue I found, which both of them you can here in my test record:
- A weird buzzing sound
- Doing a slide on my midi keyboard (or on the virtual on screen keyboard) can cause notes being shortcut for some reason. This issue was already present in the older versions of VSTSynthFont.

https://www.dropbox.com/s/winwnalv3zrbn ... o.mp3?dl=1

EDIT: I think the note shortcut thing has something to do with Aftertouch, perhaps you could check that.

EDIT2: Another bug:
The pitch wheel does only apply onto notes which have received a pitch bend event AFTER they have been started. So any note will always play at default pitch but moving a completely bent down pitch wheel ever so slightly will suddenly make the note slide down to its desired pitch.
used to be "likeaguest"

Admin
Site Admin
Posts: 356
Joined: Tue Mar 17, 2015 9:22 am

Re: VSTSynthFont hangs when playing instruments for the first time

Post by Admin » Thu Nov 02, 2017 5:09 pm

Thanks Mike,
For some odd reason I can't get VstHost to "listen" to my Virtual Midi Keyboard (I don't have hardware) so I cannot directly reproduce the findings you report (buzzing sound, notes shortcut when doing a slide) but I know for a fact that having VSTSynthFont loaded in SynthFon2, there are no issues when playing on SynthFont2's internal virtual keyboard.

The other issues I will look into in due time.

mike
Posts: 27
Joined: Thu Mar 19, 2015 10:14 pm

Re: VSTSynthFont hangs when playing instruments for the first time

Post by mike » Thu Nov 02, 2017 8:41 pm

Actually, you don't need an external Virtual Midi Keyboard in VSTHost because it already has one built in (can be used by either keyboard or mouse).
used to be "likeaguest"

Admin
Site Admin
Posts: 356
Joined: Tue Mar 17, 2015 9:22 am

Re: VSTSynthFont hangs when playing instruments for the first time

Post by Admin » Fri Nov 03, 2017 7:33 am

Oh yes, I've been using an old version. Got the latest one now, and it works OK. I do not hear anything strange just by pulling the mouse as quickly as I can over the virtual keyboard. I'll continue to investigating other matters.

Admin
Site Admin
Posts: 356
Joined: Tue Mar 17, 2015 9:22 am

Re: VSTSynthFont hangs when playing instruments for the first time

Post by Admin » Fri Nov 03, 2017 12:24 pm

Here's a new version:
https://www.dropbox.com/s/2lgih6cauq69g ... C.rar?dl=0
There was one bug related to Pitch Wheel and another related to Aftertouch.
Any better?

notsevendy
Posts: 6
Joined: Tue Apr 05, 2016 6:36 pm

Re: VSTSynthFont hangs when playing instruments for the first time

Post by notsevendy » Wed Apr 18, 2018 3:31 pm

Has this problem been closed out? I've been using VSTSynthFont in two hosts, VSTHost and Anvil Studio, for a long time. Problems of some sort (I don't remember what) caused me to revert to version 1.073. Not willing to leave well enough alone (actually, it's because 1.073 does not recognize "fixed" velocities defined in the SoundFont), today I tried 1.096, and, as is mentioned above, I get a "weird buzzing" distortion in both hosts. Also, VSTHost crashes on closing.

Yikes! What happened?

Admin
Site Admin
Posts: 356
Joined: Tue Mar 17, 2015 9:22 am

Re: VSTSynthFont hangs when playing instruments for the first time

Post by Admin » Fri Apr 27, 2018 6:05 am

VSTSynthFont has been a problematic piece of software for ages (always). I have now been able to create a version stable also in Cubase. This is the 64 bit version as Cubase is a 64 bit host. But the 32 bit version should be equally stable. I will tell you when I have something ready for you to try.

notsevendy
Posts: 6
Joined: Tue Apr 05, 2016 6:36 pm

Re: VSTSynthFont hangs when playing instruments for the first time

Post by notsevendy » Fri Apr 27, 2018 2:58 pm

I'm surprised that you say that it's always been problematic, even though it's your baby. I use it ALL THE TIME, and, other than this one quirk that I mentioned, it's never given me any problem--version 1.073, anyway. As far as I can tell, there's nothing quite like it as a VSTi! Most of the VST Soundfont players are useless, and none that I know of come close to VSTSynthFont. As a fan of your work, I'm just concerned that version 1.096 has been the public face of VSTSynthFont for over a year now, and it appears to me to be thoroughly broken. Although I keep old versions, I don't know if a new user could find an old version on your website--I couldn't, although I did some digging, and found some on the Internet Archive Wayback Machine.

Admin
Site Admin
Posts: 356
Joined: Tue Mar 17, 2015 9:22 am

Re: VSTSynthFont hangs when playing instruments for the first time

Post by Admin » Mon Apr 30, 2018 8:39 am

I'm glad you have found it useful!
However, I have received SO MANY complaints and bad feed back throughout these years so I have many times thought about discontinuing it all. But I decided this year to give it another year. This is probably the last one. If you want to try the latest test version, you find it here:
The 32 bit version:
https://www.dropbox.com/s/bcc3xtuscp4xz ... 3.rar?dl=0
The 64 bit version:
https://www.dropbox.com/s/1e6pexjq1q8ua ... 3.rar?dl=0

You will at least find that he GUI has changed completely. The visual themes I offered before were not compatible with all common hosts.

Post Reply