Reassign Problem

All about the SoundFont editor Viena
Post Reply
John Reimer
Posts: 59
Joined: Sat Mar 21, 2015 11:29 pm

Reassign Problem

Post by John Reimer »

Kenneth,

I am finding that I cannot reassign samples using Viena 1.131 or 1.133. I can do it with 1.121.
This is with a small soundfont and using Windows 8.1.

By the way, the 1.131.and 1.133 are both 32-bit, but the 1.121 is 64-bit, as it happens.

John Reimer

Admin
Site Admin
Posts: 508
Joined: Tue Mar 17, 2015 9:22 am

Re: Reassign Problem

Post by Admin »

Just tried it now in 1.133 using the Reassign button in Instruments/Wave data. For me it works. So what actually happens?

There is a 64 bit version of 1.133 to download, as well. (http://www.synthfont.com/Viena64Setup.exe)

John Reimer
Posts: 59
Joined: Sat Mar 21, 2015 11:29 pm

Re: Reassign Problem

Post by John Reimer »

Kenneth,

1.131 and 1.133 were not showing the samples list when I clicked on Reassign.

However........ I have just installed the 64-bit version of 1.133 on my Windows 8.1 laptop, and not only does it behave, but so do the two 32-bit versions! Computers do keep us guessing.

John Reimer

Admin
Site Admin
Posts: 508
Joined: Tue Mar 17, 2015 9:22 am

Re: Reassign Problem

Post by Admin »

They sure have a life of their own! The soul of Claude Shannon lingering on in the microchips.

John Reimer
Posts: 59
Joined: Sat Mar 21, 2015 11:29 pm

Re: Reassign Problem

Post by John Reimer »

Kenneth,

I think my success with this problem was short-lived, and I had to return to using 1.121 for reassigns and possibly also for actually importing looped samples where I had removed the release section (I have forgotten the proper term). I'm a bit vague on this, as it's some time I finished the 10 months work on my latest (and possibly last) soundfont. Let me say that (as I have already said in previous posts) I have used Viena for many years, and it has been indispensable in achieving remarkable results. I am truly grateful.

I have certainly worked around this problem, without any concerns. I am sending this report because in the jOrgan community I am not the only user with problems with recent versions of Viena. Here are quotes from two users, sent to the latest thread on the jOrgan-User Forum:

"It appears that soundfonts edited in the later version of Viena 1.151 won't load in jOrgan 3.20, at least not running in Win 7/64.  How was I to know??  I do have an earlier Viena 1.410 on another machine, so I'll use that for all editing.  Viena 1.151 is the kiss of death for my soundfonts!"

"I have reverted back to version 0.960 years ago with which I have no problems, having had problems with newer versions, which I use on Windows 8.1 and XP."

For the record, I don't think I have been using any version later than 1.133, and even with that one I was certainly having problems.

John Reimer

Post Reply