Edited Instruments Splits in Viena, now all samples are broken

All about the SoundFont editor Viena
mike
Posts: 24
Joined: Thu Mar 19, 2015 10:14 pm

Edited Instruments Splits in Viena, now all samples are broken

Postby mike » Sat Oct 08, 2016 1:05 pm

Hello everyone,

so I've been using Viena lately to work on one of my soundfonts today. I imported some new samples, created a few new instrument splits, moved existing splits and did some other various things.
However, now quite a few samples are broken now and contain parts and pieces of other samples (like file pointers to random file locations). For some instruments the loops now how negative values for some reason.
Here is a sample file: https://dl.dropboxusercontent.com/u/285 ... ection.sf2

I'd guess the damage is not repairable which isn't a big problem for me since I do have some older backups.
On the other hand I'd like to edit SF2s with that happening again.

Any clue what could go wrong?

Best Regards,
Mike
used to be "likeaguest"

Admin
Site Admin
Posts: 284
Joined: Tue Mar 17, 2015 9:22 am

Re: Edited Instruments Splits in Viena, now all samples are broken

Postby Admin » Sun Oct 09, 2016 7:58 am

Hi Mike,
This is very difficult to reproduce. AND it is very difficult to understand, as there are no reason for sample data to become mixed with other samples. But of course it can happen if some pointers get scrambled. I will investigate. It would help if you could figure out what steps you need to take to cause this to happen.

mike
Posts: 24
Joined: Thu Mar 19, 2015 10:14 pm

Re: Edited Instruments Splits in Viena, now all samples are broken

Postby mike » Fri Oct 14, 2016 12:36 pm

I haven't been able to reproduce this unfortunately. I somehow managed to make one of my instrument splits vanish, but same issue with that one as well.
I'll post once I get a more interesting update on this.
used to be "likeaguest"

Admin
Site Admin
Posts: 284
Joined: Tue Mar 17, 2015 9:22 am

Re: Edited Instruments Splits in Viena, now all samples are broken

Postby Admin » Tue Oct 18, 2016 7:29 am

Thanks,
I thought so. I have also received a similar comment from another user - without steps to reproduce - but he seems to believe it is the "purge unused items" command that causes havoc. I am looking into it right now. I have a new version in the baking that has a quite different sample handling structure and hence will require a lot of testing.

John Reimer
Posts: 51
Joined: Sat Mar 21, 2015 11:29 pm

Re: Edited Instruments Splits in Viena, now all samples are broken

Postby John Reimer » Tue Oct 18, 2016 7:49 pm

Admin wrote: I have also received a similar comment from another user


Kenneth,

Perhaps you are referring to the problems I have been reporting with version 0.992, wherein I had become suspicious of the soundfont I have been building. It involved a lot of reassigns, and a lot of purging of unwanted samples. A few days ago as I was adding the very last preset, the soundfont finally became unusable. Even version 0.780 would not handle it. I was faced with the prospect of starting all over again. At least I had the samples, but it was going to be a major task entering in all the parameters. Fortunately all I had to do was to make a New File, and copy into it all the presets except the last one. I then made that final preset up as a separate New File, and successfully copied it into the main (new) soundfont. I used 0.992 for this whole process, and it behaved itself completely.

Perhaps this report is relevant.

John Reimer

Admin
Site Admin
Posts: 284
Joined: Tue Mar 17, 2015 9:22 am

Re: Edited Instruments Splits in Viena, now all samples are broken

Postby Admin » Wed Oct 19, 2016 6:14 am

Thanks John,
I believe I have identified the code lines causing all of these problems. It is all down to how the deletion of unused samples is handled. I have done a lot of work lately to clean up this process and I am confident in that version 0.993 will be up to the job. I am still running tests myself - more than ever before - and as soon as I am ready (hopefully still today) I will release a test version here for anyone to try.

Admin
Site Admin
Posts: 284
Joined: Tue Mar 17, 2015 9:22 am

Re: Edited Instruments Splits in Viena, now all samples are broken

Postby Admin » Thu Oct 20, 2016 12:50 pm

I have now completed one set of rather extensive tests, but to become really confident in the latest test version I definitely need input from other people. I know I will get this input if I simply release this version now, but I want to hold back for a few days still (more tests are in the baking...). But, for anyone who wants to help, here is the next test version:
https://dl.dropboxusercontent.com/u/173 ... a0993C.rar

John, I've run the "replace samples" routine many times now and it seems to work.

For those interested in some technical nitty-gritty I can share them. One reason for the latest versions (since version 0.979) having major problems with removing samples is the way sample data records are stored. Since version 0.979 records are stored in a "generic list" and not in a simple array. Up to now sample data records (in the list) have been referenced in two ways: either with a integer index into the list storing the records, or as a memory pointer directly pointing the a record. The later method is the only safe one, as the memory occupied by a record never changes. But the index in the list WILL change as soon as records are deleted from the list. Thus, to avoid this potential hazard I have now removed 99.9% of all list indexing. (Why not 100%? Simply because the SoundFont file contains indexes; thus pointers must be converted to indexes when saving the file.)

Admin
Site Admin
Posts: 284
Joined: Tue Mar 17, 2015 9:22 am

Re: Edited Instruments Splits in Viena, now all samples are broken

Postby Admin » Fri Oct 21, 2016 5:41 am

Nope... Version 0.993C isn't good enough... Withdrawn.

Admin
Site Admin
Posts: 284
Joined: Tue Mar 17, 2015 9:22 am

Re: Edited Instruments Splits in Viena, now all samples are broken

Postby Admin » Fri Oct 21, 2016 8:15 am

Here is a working one:
https://dl.dropboxusercontent.com/u/173 ... a0993D.rar

In version "C" there was a minor bug in the Save File routine that made some presets loose there layers after a number of instruments had been removed.

John Reimer
Posts: 51
Joined: Sat Mar 21, 2015 11:29 pm

Re: Edited Instruments Splits in Viena, now all samples are broken

Postby John Reimer » Sun Oct 23, 2016 1:05 am

Kenneth,

I am not in a position to do a comprehensive test on 0.993D, but I have tried it on a few of the fairly basic routines which I use a lot. It seems so far to be behaving itself for me, but I did notice two matters where its behaviour is different to what I am used to with previous versions:

1. When I do a Reassign, using the Instrument Global view (as is normal), instead of reverting to the Global view which would allow me to change the RK immediately, Viena selects the Instrument “name” line just above Global (in the Instrument list at the left). So it requires an extra mouse action before I can enter that new RK value. Not the end of the world, but a little frustrating.

2. When I Add a new sample where a sample of that name is already in the soundfont, I am used to being told that a sample of that name already exists. That warning no longer occurs, and I think that is undesirable. The warning is valuable, in my opinion, as it is good to know exactly where one stands. However, it is possible that after some reflection, I may decide otherwise. (As a further test, I actually went through this test process in two ways a) where the sample being added was IDENTICAL to the sample of that name already in the soundfont b) where I had altered the sample slightly, but retained the name. Both times the sample was added by Viena without issuing that warning).

John Reimer


Return to “Viena”

Who is online

Users browsing this forum: No registered users and 1 guest