Edited Instruments Splits in Viena, now all samples are broken

All about the SoundFont editor Viena
Admin
Site Admin
Posts: 230
Joined: Tue Mar 17, 2015 9:22 am

Re: Edited Instruments Splits in Viena, now all samples are broken

Postby Admin » Sun Oct 23, 2016 3:35 pm

Thanks John. Notes taken.

Admin
Site Admin
Posts: 230
Joined: Tue Mar 17, 2015 9:22 am

Re: Edited Instruments Splits in Viena, now all samples are broken

Postby Admin » Mon Oct 24, 2016 8:58 am

Here is the next version:
https://dl.dropboxusercontent.com/u/173 ... a0993E.rar

1) Indeed, minor flaw in the last few test versions. Fixed.
2) This confirmation box was displayed only for stereophonic samples (new flaw) in the last few versions. Additionally I had plans to introduce a Cancel button to the dialog to give you a chance to opt out and rethink the strategy. Done that now and fixed the flaw.

More? Anyone?

Admin
Site Admin
Posts: 230
Joined: Tue Mar 17, 2015 9:22 am

Re: Edited Instruments Splits in Viena, now all samples are broken

Postby Admin » Fri Nov 04, 2016 8:36 am

I have today released the official 0.993 version of Viena. If you have any 0.993 version you you should definitely update, as the official version has many more bug fixes! Here is a link to the setup file: http://www.synthfont.com/VienaSetup.exe or just an archive for update: http://www.synthfont.com/Viena.zip.

sammy
Posts: 8
Joined: Thu Oct 01, 2015 7:01 am

Re: Edited Instruments Splits in Viena, now all samples are broken

Postby sammy » Thu Nov 10, 2016 10:38 am

Hello!
In all versions after .0993B Viena crashes when external midi keyboard is used.
It makes impossible trying any soundfont with a keyboard.

Admin
Site Admin
Posts: 230
Joined: Tue Mar 17, 2015 9:22 am

Re: Edited Instruments Splits in Viena, now all samples are broken

Postby Admin » Tue Nov 15, 2016 9:42 am

Yepp! I know. A new version is on the way. While you wait you may want to test this test version:
https://dl.dropboxusercontent.com/u/1733095/Viena0994A.rar

Admin
Site Admin
Posts: 230
Joined: Tue Mar 17, 2015 9:22 am

Re: Edited Instruments Splits in Viena, now all samples are broken

Postby Admin » Thu Nov 17, 2016 4:22 pm

Version 0.994 is out now.

John Reimer
Posts: 32
Joined: Sat Mar 21, 2015 11:29 pm

Re: Edited Instruments Splits in Viena, now all samples are broken

Postby John Reimer » Sun Dec 18, 2016 10:44 am

Kenneth,

I'm back to making a new soundfont, and have been using 0.994 without issues. However, today it would not let me delete splits (greyed out), and I had to use 0.780. I have had this problem before, with the recent versions.

John Reimer

Admin
Site Admin
Posts: 230
Joined: Tue Mar 17, 2015 9:22 am

Re: Edited Instruments Splits in Viena, now all samples are broken

Postby Admin » Wed Dec 28, 2016 10:50 am

Thanks John, I'll look around for a solution.

mike
Posts: 14
Joined: Thu Mar 19, 2015 10:14 pm

Re: Edited Instruments Splits in Viena, now all samples are broken

Postby mike » Sun Jan 15, 2017 8:44 pm

Well, I don't know if it has anything to do with that, but now I have a similar issue (don't have a file of that) after I purged a bunch of unused samples and instruments.
After adding a new sample and instrument now
my GB Noise instrument plays Piano sounds even though the samples still display the Noise Samples and those don't seem to be broken.
Check out the broken Soundfont here, it hopefully helps investigation:
https://dl.dropboxusercontent.com/u/285 ... ection.sf2

PS: Where can I get the older versions? The issue with adding a sample seems to becurrently unavoidable and I'd like to continue my work as soon as possible.
used to be "likeaguest"

Admin
Site Admin
Posts: 230
Joined: Tue Mar 17, 2015 9:22 am

Re: Edited Instruments Splits in Viena, now all samples are broken

Postby Admin » Mon Jan 16, 2017 11:50 am

There's nothing wrong with the SoundFont!

But - the strange thing is that I have also once (only once) experienced that piano sounds where played instead of the noise sounds when fooling around with your SoundFont. I think it happened immediately after I had opened the font. Then I did some clicking here and there and suddenly - it played the noise sounds! So, the flaw is not in the SoundFont but in the current Viena version. Now that I have been able to achieve this effect once, I know what to look for and think I know the reason for the flaw: when an Instrument which is not used by any Preset is selected the Preset becomes undefined and the previous Preset may remain in action. I will offer you a new test version soon with a fix!

I have not been able to reproduce a grayed out Delete function. However, I did find one minor flaw: the Delete function must be grayed out when the Global split is selected. Fixed in next (test) version.


Return to “Viena”

Who is online

Users browsing this forum: No registered users and 1 guest