New test version

All about the development and use of SynthFont2
Admin
Site Admin
Posts: 284
Joined: Tue Mar 17, 2015 9:22 am

Re: New test version

Postby Admin » Thu Sep 03, 2015 5:05 pm

Cos(e) - thanks again for your thoughts. I think all of this should be filed under "wish list" and not under "New test version".
On par with this is another design issue: I have plans to add various GUI alternatives to the program. There was a rather nice proposition some time ago from either Elven or Ray890, but I have lost it. There was an image with some of the GUI elements reordered into a more compact form - I thought I had saved that image, but obviously not. So if the author reads this and realizes what I am referring to, then please step forward.

I have created a new version:
https://dl.dropboxusercontent.com/u/173 ... t2023F.rar

This is the one I hope to be able to release soon. It is mostly a set of bug fixes. For example, these ones mentioned by ray890 earlier have been fixed or otherwise addressed:
+ The black playback indicator line in Pianoroll and Plug & Play do not show when "scroll to" mode is set to Nothing - Hmm... I guess this is what you would expect? "Nothing" means "nothing". Or?
+ The tracks list at the upper left do not show their proper Pianoroll colors - cannot reproduce
+ In Pianoroll, dragging the preview thumb to the end doesn't take you to the complete end of the song - fixed
+ Making the Pianoroll window horizontally larger when scrolled at the end will cause the preview thumb to become temporarily stiff - fixed
+ Zooming horizontally in the Pianoroll causes abnormal behavior and excessively scrolls the track - fixed
+ Auto-scrolling of MIDI Events does not work - fixed
+ Auto-scrolling in Pianoroll does not work when the window is popped out - fixed

To pop out a tab page you must now use the new button instead of the popup menu I had in the first version.

There are quite a few bug fixes in this version but I will not list them here.

Another change that I may need to return to is this one: thread priorities. I have set the priority of the rendering threads higher in this version. It seems to be required when using a large number of VST instruments in order to keep the sound intact when playing to the speakers. I find this very strange and I will need to investigate further.

tayfun
Posts: 20
Joined: Tue Mar 17, 2015 3:53 pm

Re: New test version

Postby tayfun » Fri Sep 04, 2015 9:07 am

Hi kenneth...
A few things I'd like to add

1. deleting notes on the piano roll causes crash

2. working with Ample Sound vst's causes crash

3. The program opens small window everytime not full screen

4. deleting a marker on the piano roll doesnt work. it still stays on the playback range window
and the song starts at that time again. to get rid of this we have to click a few buttons more

5. Solo function works with a delay again

6. Changing sounfonts while playing is not effective anymore. have to stop and start to hear the new sound

thanks a lot. best regards

ray890
Posts: 40
Joined: Tue Mar 17, 2015 4:27 pm
Contact:

Re: New test version

Postby ray890 » Wed Sep 09, 2015 4:00 am

I have no clue what happened, I was unsubscribed to this topic somehow for a while, anyway I'm back.

Now, to add to what I reported earlier, I've done more extensive testing in relation to the 3+ cores issue. It seems to show that it's around 48Khz when slowdowns seem to occur, meanwhile higher sample rates seemed to gear towards expectantly having higher render times. Note: These tests were done all with build "D", but build F doesn't seem to have any differences in terms of this bug.

I checked again, it seems the inaccurate Pianoroll track color issue seems to be very MIDI file specific. It seems to happen more often with large files, those whose tracks get split, and others for unknown reasons if any. Examples: here

I expected the Pianoroll's "Nothing" option to indeed not automatically scroll the Pianoroll display, but I don't see how that has anything to do with the need to take away the playback indicator line. What I expected was to see the moving indicator line present, just not have the Pianorolls display automatically follow it, therefore I considered that as a bug.

Ok, I now see the proper context menu added to the single-line "Track to edit" box. That works but I was thinking that belonged in the multi-line above that, provided the user's actually right clicking a list entry rather than white space, and that the list entry gets highlighted as it's being right clicked on.

Now, the only new thing I got to say regarding build "F" so far is that the new "Show tab in separate window" button could use a bit of re-sizing in order to look proper in the design.

Admin
Site Admin
Posts: 284
Joined: Tue Mar 17, 2015 9:22 am

Re: New test version

Postby Admin » Tue Sep 15, 2015 5:17 pm

Here is version "H":
https://dl.dropboxusercontent.com/u/173 ... t2023H.rar

Major change: having several VST instruments may cause cracks in the speaker sound due to CPU overload. In order to improve upon this I now run the VSTi processing in separate threads to facilitate the use of multiple CPU cores. (Still waiting for my own quad-core PC).

Taifun found these:
1. deleting notes on the piano roll causes crash - fixed
2. working with Ample Sound vst's causes crash - I've only got the free version of it and it doesn't crash
3. The program opens small window everytime not full screen - only when you had a styled GUI. Fixed.
4. deleting a marker on the piano roll doesnt work. it still stays on the playback range window - fixed
5. Solo function works with a delay again - depends on the size of the playback buffer (see Setup and Options)
6. Changing sounfonts while playing is not effective anymore - cannot reproduce

More:
ray890 wanted the Pianoroll playback cursor to stay visible even if the scroll method is set to "Nothing". Finally I realized that there actually was a major shortcoming when it is set to Nothing: there is no playback cursor in the mini pianoroll windows - one beneath the large one, and the other above the tracks list, These windows definitely should have a playback cursor all the time. So now they do. Also the large pianoroll has one now, even if it quickly may disappear to the right.

If you deleted a midi track there was no indication that the arrangement had changed also (if there was one). It is important to save the arrangement if you change the number of midi tracks (or the order). A warning is now issued to make you - force you - save the arrangement immediately.

Lost of other minor changes and bugs fixes (of course). I won't bother you with the details.

Admin
Site Admin
Posts: 284
Joined: Tue Mar 17, 2015 9:22 am

Re: New test version

Postby Admin » Fri Sep 25, 2015 8:35 am

Here is version "I":
https://dl.dropboxusercontent.com/u/1733095/SynthFont2023I.rar

Fixed one critical bug: after using the Live Input mode, SynthFont2 (since 2.0.2.0) did not release the MIDI in port so you could not initiate a new session without exiting.

There is now an option in Setup and Options (page Options 2) to tell SynthFont2 whether or not to use multiple CPU cores for VST instruments. (If you only have one VSTi, then this has no meaning of course.)

Cos
Posts: 14
Joined: Wed Mar 18, 2015 2:32 am

Re: New test version

Postby Cos » Sun Oct 04, 2015 1:54 pm

Two bugs (2.0.2.2 version:

- First one is a recurrent bug. Setup and Options settings aren't saved in between sessions. That's an important bug.

- Second one is that the excellent internal Synthfont file explorer doesn't work as it used to -it always was an essential feature. Functions like Open, copy or Open with do nothing at all, and they were basic to open other programs, open files externally, copy files within Synthfont in order to paste them later, etc etc etc etc.

Admin
Site Admin
Posts: 284
Joined: Tue Mar 17, 2015 9:22 am

Re: New test version

Postby Admin » Tue Oct 06, 2015 9:52 am

I guess you have closed the window using the top-right [X]? Pressing the Save button saves everything.

Cos
Posts: 14
Joined: Wed Mar 18, 2015 2:32 am

Re: New test version

Postby Cos » Wed Oct 07, 2015 4:29 pm

Well, it doesn't work that way in my computer, Kenneth. That makes it impossible for me to open different files from the Internet. I check the following steps:

MIDI Input Port: SD-50
audio input port: SD-50
Device: SD-50
- GM2 Yes. SysEx. Yes.
Even in the same session, after I press Save and return back, GM2 Yes and SysEx Yes, have returned to GM1 No, SysEx No.

Admin
Site Admin
Posts: 284
Joined: Tue Mar 17, 2015 9:22 am

Re: New test version

Postby Admin » Wed Oct 07, 2015 4:40 pm

So is ONLY the GM2 and SysEx settings that bother you?

Cos
Posts: 14
Joined: Wed Mar 18, 2015 2:32 am

Re: New test version

Postby Cos » Wed Oct 07, 2015 6:46 pm

partially.., yes Kenneth. your gm2 sysex enables the native presets of the hardware in several DAWs, even in Music Creator 6 Touch and Sonar 8.5, but the thing is that the settings aren't saved like they used to be because it-s not only that but the Microsoft GS Wavetable Synth is selected by default every time, so the setup and options settings are reseted every time.

Plus the "Use selected device instead of any SOUNDFONT or VST arrangement is not found..." is unchecked if you restart. It wasn't like that before.

cheers Kenneth :)

edit: oddly enough, even if I chose "GM2-->Yes", it doesn't matter (visually at least) "GM1-->No" are the default options -though the the gm2 sysEx and mode work properly most of the time- and they show like that when you re-enter the Setup and Options window. However, since I had changed to GM2-->Yes in the same session, if you double click GM1-->No, GM2 and Yes are correctly selected according to the mini window that appears.

additionally, if you restart Synthfont, it returns to GM1-->No and the other typical options.


Return to “SynthFont2”

Who is online

Users browsing this forum: No registered users and 1 guest